A flaw was found in Ansible in the amazon.aws collection when using the tower_callback…
Priority LOW 35CWE-233Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A flaw was found in Ansible in the amazon.aws collection when using the tower_callback parameter from the amazon.aws.ec2_instance module. This flaw allows an attacker to take advantage of this issue as the module is handling the parameter insecurely, leading to the password leaking in the logs.
Why it matters now
EPSS 0.00902 59th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 7.0.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ansible, ansible community.aws, ansible amazon.aws | ansible from 2.5.0 before 2.10; ansible community.aws before 2.0.0; ansible amazon.aws from 2.1.0 before 5.1.0 | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.5.0 to before 7.0.0 | 7.0.0 | Patch available | GHSA-cpx3-93w7-457x |
- ansible, ansible community.aws, ansible amazon.aws Vendor— Affected ansible from 2.5.0 before 2.10; ansible community.aws before 2.0.0; ansible amazon.aws from 2.1.0 before 5.1.0 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.5.0 to before 7.0.0 Fixed in 7.0.0 Patch available GHSA-cpx3-93w7-457x
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* | 2.5.0 to before 2.10.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_collection:*:*:*:*:*:community_aws:*:* | before 2.0.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_collection:*:*:*:*:*:aws:*:* | 2.1.0 to before 5.1.0 | Vulnerable | Red Hat |
- cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions 2.5.0 to before 2.10.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_collection:*:*:*:*:*:community_aws:*:* Versions before 2.0.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_collection:*:*:*:*:*:aws:*:* Versions 2.1.0 to before 5.1.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-cpx3-93w7-457x ansible (PyPI) Fixed in 7.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3697
- 2026-10-03 Alias added: GHSA-cpx3-93w7-457x
References
Advisory 2
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-3697 · CVE Program
- CVE-2022-3697 · NVD
- FIRST EPSS
- GHSA-cpx3-93w7-457x · GitHub Advisory Database · CC BY 4.0
- CVE-2022-3697 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences