Appointment Hour Booking <= 1.3.72 - CAPTCHA Bypass
Priority LOW 31CWE-804Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-326.
Summary
The Appointment Hour Booking plugin for WordPress is vulnerable to CAPTCHA bypass in versions up to, and including, 1.3.72. This is due to the use of insufficiently strong hashing algorithm on the CAPTCHA secret that is also displayed to the user via a cookie.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00491 42nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codepeople | Appointment Hour Booking – Booking Calendar | up to 1.3.72 | — | No fix listed | CNA |
- Appointment Hour Booking – Booking Calendar Vendorcodepeople Affected up to 1.3.72 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4036
- 2026-10-03 Alias added: GHSA-5cwm-9hm2-r3cf
References
More codepeople vulnerabilities
- TI-2024-00790 Booking Calendar < 1.3.83 - CSRF appointment scheduling CVSS 3.1HIGH 8.8
- TI-2024-11385 BookingPress < 1.1.23 - Unauthenticated Export File Download CVSS 3.1HIGH 7.5
- TI-2024-03387 Smart Image Gallery < 1.0.19 - Update/Delete Google API Key via CSRF CVSS 3.1MEDIUM 6.8
- TI-2023-05486 Contact Form Email < 1.3.44 - Editor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-08220 Polls CP <= 1.0.75 - Admin+ Stored XSS via Custom Styles CVSS 3.1MEDIUM 5.4
- TI-2024-08217 Polls CP <= 1.0.75 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-4036 · CVE Program
- CVE-2022-4036 · NVD
- FIRST EPSS
- GHSA-5cwm-9hm2-r3cf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences