Improperly Controlled Modification of Dynamically-Determined Object Attributes in librenms/librenms
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-915 and CWE-79.
Summary
A user is able to enable their own account if it was disabled by an admin while the user still holds a valid session. Moreover, the username is not properly sanitized in the admin user overview. This enables an XSS attack that enables an attacker with a low privilege user to execute arbitrary JavaScript in the context of an admin's account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms/librenms | before 22.10.0 | 22.10.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 22.10.0 | 22.10.0 | Patch available | GHSA-f3hw-3h74-wr98 |
- librenms/librenms Vendorlibrenms Affected before 22.10.0 Fixed in 22.10.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 22.10.0 Fixed in 22.10.0 Patch available GHSA-f3hw-3h74-wr98
Remediation
- Fix · CNA librenms/librenms (librenms) Fixed in 22.10.0
- Fix · GHSA-f3hw-3h74-wr98 librenms/librenms (Packagist) Fixed in 22.10.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
librenms/librenms 22.10.0
8 records Highest priority Priority HIGH 5 HIGH, 3 MEDIUM
Other records, highest priority first
- TI-2022-03735 Insufficient Session Expiration in librenms/librenmsPriority HIGH 75
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenmsPriority HIGH 73
- TI-2022-03732 Cross-site Scripting (XSS) - Stored in librenms/librenmsPriority HIGH 68
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4068
- 2026-10-03 Alias added: GHSA-f3hw-3h74-wr98
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-4068 · CVE Program
- CVE-2022-4068 · NVD
- FIRST EPSS
- GHSA-f3hw-3h74-wr98 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences