Deserialization of Untrusted Data in Codeigniter4
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codeigniter4 | CodeIgniter4 | before 4.1.6 | 4.1.6 | Patch available | CNA |
| — | codeigniter4/framework (Packagist) | before 4.1.6 | 4.1.6 | Patch available | GHSA-w6jr-wj64-mc9x |
- CodeIgniter4 Vendorcodeigniter4 Affected before 4.1.6 Fixed in 4.1.6 Patch available CNA
- codeigniter4/framework (Packagist) Vendor— Affected before 4.1.6 Fixed in 4.1.6 Patch available GHSA-w6jr-wj64-mc9x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* | 4.0.0 to before 4.1.6 | Vulnerable | codeigniter4 |
- cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.1.6 Vulnerable ·codeigniter4
Remediation
- Fix · CNA CodeIgniter4 (codeigniter4) Fixed in 4.1.6
- Fix · GHSA-w6jr-wj64-mc9x codeigniter4/framework (Packagist) Fixed in 4.1.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21647
- 2026-10-03 Alias added: GHSA-w6jr-wj64-mc9x
References
Advisory 2
More codeigniter4 Codeigniter vulnerabilities
- TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
- TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
- TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
- TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
- TI-2024-19671 CodeIgniter4 Language class DoS Vulnerability CVSS 3.1HIGH 7.5
- TI-2022-18660 Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued in Codeigniter4 CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-21647 · CVE Program
- CVE-2022-21647 · NVD
- FIRST EPSS
- GHSA-w6jr-wj64-mc9x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences