Priority HIGH 80
CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.72161 · Published 2017-09-19 · Fixed in 3.0.0, 3.3.3 CWE-310
Priority HIGH 71
Shield is an authentication and authorization framework for CodeIgniter 4.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00611 · Published 2022-08-12 · Fixed in 1.0.0-beta.2 CWE-352
Priority HIGH 69
CodeIgniter is an open source PHP full-stack web framework.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.37671 · Published 2022-01-04 · Fixed in 4.1.6 CWE-502
Priority HIGH 68
A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily change the Administrator password and escalate privileges.
CVSS 3.1HIGH 7.5· Network · Low privileges · No interaction · EPSS 0.0023 · Published 2024-10-15 · No fix listed CWE-352
Priority HIGH 68
CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by leveraging fallback to a custom XOR-based encryption scheme when the Mcrypt extension for PHP is not available.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.37222 · Published 2017-09-19 · No fix listed CWE-310
Priority HIGH 66
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00773 · Published 2024-03-29 · Fixed in 4.4.7 CWE-835
Priority MEDIUM 53
CodeIgniter is a PHP full-stack web framework.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.01122 · Published 2022-10-06 · Fixed in 4.2.7 CWE-665
Priority MEDIUM 51
CodeIgniter is a PHP full-stack web framework.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01126 · Published 2023-05-30 · Fixed in 4.3.5 CWE-94
Priority MEDIUM 51
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where_not_in() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 51
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_like() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 51
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where_not_in() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 51
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01042 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 51
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_having() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 51
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 50
CodeIgniter is a PHP full-stack web framework.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00912 · Published 2022-12-22 · Fixed in 4.2.11 CWE-287
Priority MEDIUM 50
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01173 · Published 2022-02-28 · Fixed in 4.1.9 CWE-20
Priority MEDIUM 48
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03114 · Published 2017-01-12 · Fixed in 3.1.3 CWE-74
Priority MEDIUM 47
SQL injection vulnerability in the offset method in the Active Record class in CodeIgniter before 2.2.4 allows remote attackers to execute arbitrary SQL commands via vectors involving the offset variable.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02321 · Published 2018-02-21 · No fix listed CWE-89
Priority MEDIUM 46
CodeIgniter is a PHP full-stack web framework.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01503 · Published 2025-07-28 · Fixed in 4.6.2 CWE-78
Priority MEDIUM 45
A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01504 · Published 2018-06-17 · Fixed in 3.1.10 CWE-384
Priority MEDIUM 44
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 44
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_not_like() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 44
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where_in() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 44
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php having() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Priority MEDIUM 44
B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php like() function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01091 · Published 2022-10-07 · No fix listed CWE-89
Load more