An issue was discovered in phpMyAdmin 5.1 before 5.1.2.
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in phpMyAdmin 5.1 before 5.1.2. An attacker can inject malicious code into aspects of the setup script, which can allow XSS or HTML injection.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.07936 94th percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 5.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 5.1.0 to before 5.1.2 | 5.1.2 | Patch available | GHSA-vcwc-6mr9-8m7c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 5.1.0 to before 5.1.2 Fixed in 5.1.2 Patch available GHSA-vcwc-6mr9-8m7c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* | 5.1.0 to before 5.1.2 | Vulnerable | phpMyAdmin |
- cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 5.1.0 to before 5.1.2 Vulnerable ·phpMyAdmin
Remediation
- Fix · GHSA-vcwc-6mr9-8m7c phpmyadmin/phpmyadmin (Packagist) Fixed in 5.1.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23808
- 2026-10-03 Alias added: GHSA-vcwc-6mr9-8m7c
References
Other 5
- https://infosecwriteups.com/exploit-cve-2022-23808-85041c6e5b97
- https://github.com/phpmyadmin/phpmyadmin/commit/44eb12f15a562718bbe54c9a16af91ceea335d59
- https://github.com/phpmyadmin/phpmyadmin/commit/5118acce1dfcdb09cbc0f73927bf51c46feeaf38
- https://github.com/phpmyadmin/phpmyadmin
- https://www.phpmyadmin.net/security/PMASA-2022-2
More Phpmyadmin vulnerabilities
- TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
- TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
- TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
- TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
- TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
Sources
- CVE-2022-23808 · CVE Program
- CVE-2022-23808 · NVD
- FIRST EPSS
- GHSA-vcwc-6mr9-8m7c · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23808 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences