Read the docs
TI-2022-08629 Aliases CVE-2022-24816GHSA-v92f-jx6p-73rx

Improper Control of Generation of Code in jai-ext

Priority CRITICAL 100Exploited in the wildCWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

JAI-EXT is an open-source project which aims to extend the Java Advanced Imaging (JAI) API. Programs allowing Jiffle script to be provided via network request can lead to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Users unable to upgrade may negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath.

Why it matters now

Exploitation Active In CISA KEV since 2024-06-26CISA due date 2024-07-17
EPSS 0.99929 99th percentileScored 2026-11-07
Fix Fixed jai-ext (geosolutions-it): 1.1.22it.geosolutions.jaiext.jiffle:jt-jiffle (Maven): 1.1.22+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geosolutions-itjai-extbefore 1.1.221.1.22Patch availableCNA
—it.geosolutions.jaiext.jiffle:jt-jiffle (Maven)before 1.1.221.1.22Patch availableGHSA-v92f-jx6p-73rx
—it.geosolutions.jaiext.jiffle:jt-jiffle-language (Maven)before 1.1.221.1.22Patch availableGHSA-v92f-jx6p-73rx
  • jai-ext Vendorgeosolutions-it Affected before 1.1.22 Fixed in 1.1.22 Patch available CNA
  • it.geosolutions.jaiext.jiffle:jt-jiffle (Maven) Vendor— Affected before 1.1.22 Fixed in 1.1.22 Patch available GHSA-v92f-jx6p-73rx
  • it.geosolutions.jaiext.jiffle:jt-jiffle-language (Maven) Vendor— Affected before 1.1.22 Fixed in 1.1.22 Patch available GHSA-v92f-jx6p-73rx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:geosolutionsgroup:jai-ext:*:*:*:*:*:*:*:*before 1.1.22VulnerableGeoNode
  • cpe:2.3:a:geosolutionsgroup:jai-ext:*:*:*:*:*:*:*:* Versions before 1.1.22 Vulnerable ·GeoNode

Remediation

  • Fix · CNA jai-ext (geosolutions-it) Fixed in 1.1.22
  • Fix · GHSA-v92f-jx6p-73rx it.geosolutions.jaiext.jiffle:jt-jiffle (Maven) Fixed in 1.1.22 Advisory →
  • Fix · GHSA-v92f-jx6p-73rx it.geosolutions.jaiext.jiffle:jt-jiffle-language (Maven) Fixed in 1.1.22 Advisory →

Timeline

  1. 2024-06-26 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2022-24816
  3. 2026-10-03 Alias added: GHSA-v92f-jx6p-73rx

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
  • TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
  • TI-2025-36983 MapServer - WFS XML Filter Query SQL injection CVSS 4.0HIGH 8.9
  • TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
See all 61 →

Sources