WPS Server Side Request Forgery in GeoServer
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | before 2.22.5; 2.23.0 to before 2.23.2 | 2.22.5, 2.23.2 | Patch available | CNA |
| — | org.geoserver.extension:gs-wps-core (Maven) | before 2.22.5 | 2.22.5 | Patch available | GHSA-5pr3-m5hm-9956 |
| — | org.geoserver.extension:gs-wps-core (Maven) | 2.23.0 to before 2.23.2 | 2.23.2 | Patch available | GHSA-5pr3-m5hm-9956 |
- geoserver Vendorgeoserver Affected before 2.22.5; 2.23.0 to before 2.23.2 Fixed in 2.22.5, 2.23.2 Patch available CNA
- org.geoserver.extension:gs-wps-core (Maven) Vendor— Affected before 2.22.5 Fixed in 2.22.5 Patch available GHSA-5pr3-m5hm-9956
- org.geoserver.extension:gs-wps-core (Maven) Vendor— Affected 2.23.0 to before 2.23.2 Fixed in 2.23.2 Patch available GHSA-5pr3-m5hm-9956
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.22.5, 2.23.2
- Fix · GHSA-5pr3-m5hm-9956 org.geoserver.extension:gs-wps-core (Maven) Fixed in 2.22.5 Advisory →
- Fix · GHSA-5pr3-m5hm-9956 org.geoserver.extension:gs-wps-core (Maven) Fixed in 2.23.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-43795
- 2026-10-03 Alias added: GHSA-5pr3-m5hm-9956
References
Advisory 2
More geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
- TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
Sources
- CVE-2023-43795 · CVE Program
- CVE-2023-43795 · NVD
- FIRST EPSS
- GHSA-5pr3-m5hm-9956 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences