GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
GeoServer is an open source server that allows users to share and edit geospatial data. GeoTools Schema class use of Eclipse XSD library to represent schema data structure is vulnerable to XML External Entity (XXE) exploit. This impacts whoever exposes XML processing with gt-xsd-core involved in parsing, when the documents carry a reference to an external XML schema. The gt-xsd-core Schemas class is not using the EntityResolver provided by the ParserHandler (if any was configured). This also impacts users of gt-wfs-ng DataStore where the ENTITY_RESOLVER connection parameter was not being used as intended. This vulnerability is fixed in GeoTools 33.1, 32.3, 31.7, and 28.6.1, GeoServer 2.27.1, 2.26.3, and 2.25.7, and GeoNetwork 4.4.8 and 4.2.13.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | 2.27.0 to before 2.27.1; 2.26.0 to before 2.26.3; before 2.25.7 | 2.27.1, 2.26.3, 2.25.7 | Patch available | CNA |
| — | org.geoserver.web:gs-web-app (Maven) | 2.27.0 to before 2.27.1 | 2.27.1 | Patch available | GHSA-jj54-8f66-c5pc |
| — | org.geoserver:gs-wfs (Maven) | 2.27.0 to before 2.27.1 | 2.27.1 | Patch available | GHSA-jj54-8f66-c5pc |
| — | org.geoserver.web:gs-web-app (Maven) | 2.26.0 to before 2.26.3 | 2.26.3 | Patch available | GHSA-jj54-8f66-c5pc |
| — | org.geoserver:gs-wfs (Maven) | 2.26.0 to before 2.26.3 | 2.26.3 | Patch available | GHSA-jj54-8f66-c5pc |
| — | org.geoserver.web:gs-web-app (Maven) | before 2.25.7 | 2.25.7 | Patch available | GHSA-jj54-8f66-c5pc |
| — | org.geoserver:gs-wfs (Maven) | before 2.25.7 | 2.25.7 | Patch available | GHSA-jj54-8f66-c5pc |
- geoserver Vendorgeoserver Affected 2.27.0 to before 2.27.1; 2.26.0 to before 2.26.3; before 2.25.7 Fixed in 2.27.1, 2.26.3, 2.25.7 Patch available CNA
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected 2.27.0 to before 2.27.1 Fixed in 2.27.1 Patch available GHSA-jj54-8f66-c5pc
- org.geoserver:gs-wfs (Maven) Vendor— Affected 2.27.0 to before 2.27.1 Fixed in 2.27.1 Patch available GHSA-jj54-8f66-c5pc
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-jj54-8f66-c5pc
- org.geoserver:gs-wfs (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-jj54-8f66-c5pc
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected before 2.25.7 Fixed in 2.25.7 Patch available GHSA-jj54-8f66-c5pc
- org.geoserver:gs-wfs (Maven) Vendor— Affected before 2.25.7 Fixed in 2.25.7 Patch available GHSA-jj54-8f66-c5pc
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:geotools:geotools:*:*:*:*:*:*:*:* | before 28.6.1; 29.0 to before 31.7; 32.0 to before 32.3 | Vulnerable | geotools |
| cpe:2.3:a:geotools:geotools:33.0:*:*:*:*:*:*:* | 33.0 | Vulnerable | geotools |
| cpe:2.3:a:osgeo:geonetwork:*:*:*:*:*:*:*:* | 4.2.0 to before 4.2.13; 4.4.0 to before 4.4.8 | Vulnerable | OSGeo |
| cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* | before 2.25.7; 2.26.0 to before 2.26.3 | Vulnerable | OSGeo |
| cpe:2.3:a:osgeo:geoserver:2.27.0:*:*:*:*:*:*:* | 2.27.0 | Vulnerable | OSGeo |
- cpe:2.3:a:geotools:geotools:*:*:*:*:*:*:*:* Versions before 28.6.1; 29.0 to before 31.7; 32.0 to before 32.3 Vulnerable ·geotools
- cpe:2.3:a:geotools:geotools:33.0:*:*:*:*:*:*:* Versions 33.0 Vulnerable ·geotools
- cpe:2.3:a:osgeo:geonetwork:*:*:*:*:*:*:*:* Versions 4.2.0 to before 4.2.13; 4.4.0 to before 4.4.8 Vulnerable ·OSGeo
- cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* Versions before 2.25.7; 2.26.0 to before 2.26.3 Vulnerable ·OSGeo
- cpe:2.3:a:osgeo:geoserver:2.27.0:*:*:*:*:*:*:* Versions 2.27.0 Vulnerable ·OSGeo
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.27.1, 2.26.3, 2.25.7
- Fix · GHSA-jj54-8f66-c5pc org.geoserver.web:gs-web-app (Maven) Fixed in 2.27.1 Advisory →
- Fix · GHSA-jj54-8f66-c5pc org.geoserver:gs-wfs (Maven) Fixed in 2.27.1 Advisory →
- Fix · GHSA-jj54-8f66-c5pc org.geoserver.web:gs-web-app (Maven) Fixed in 2.26.3 Advisory →
- Fix · GHSA-jj54-8f66-c5pc org.geoserver:gs-wfs (Maven) Fixed in 2.26.3 Advisory →
- Fix · GHSA-jj54-8f66-c5pc org.geoserver.web:gs-web-app (Maven) Fixed in 2.25.7 Advisory →
- Fix · GHSA-jj54-8f66-c5pc org.geoserver:gs-wfs (Maven) Fixed in 2.25.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30220
- 2026-10-03 Alias added: GHSA-jj54-8f66-c5pc
References
Patch 4
Advisory 2
More geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
- TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
Sources
- CVE-2025-30220 · CVE Program
- CVE-2025-30220 · NVD
- FIRST EPSS
- GHSA-jj54-8f66-c5pc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences