GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | 2.26.0 to before 2.26.2; before 2.25.6 | 2.26.2, 2.25.6 | Patch available | CNA |
| — | org.geoserver.web:gs-web-app (Maven) | 2.26.0 to before 2.26.2 | 2.26.2 | Patch available | GHSA-fjf5-xgmq-5525 |
| — | org.geoserver:gs-wms (Maven) | 2.26.0 to before 2.26.2 | 2.26.2 | Patch available | GHSA-fjf5-xgmq-5525 |
| — | org.geoserver.web:gs-web-app (Maven) | before 2.25.6 | 2.25.6 | Patch available | GHSA-fjf5-xgmq-5525 |
| — | org.geoserver:gs-wms (Maven) | before 2.25.6 | 2.25.6 | Patch available | GHSA-fjf5-xgmq-5525 |
- geoserver Vendorgeoserver Affected 2.26.0 to before 2.26.2; before 2.25.6 Fixed in 2.26.2, 2.25.6 Patch available CNA
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-fjf5-xgmq-5525
- org.geoserver:gs-wms (Maven) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-fjf5-xgmq-5525
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected before 2.25.6 Fixed in 2.25.6 Patch available GHSA-fjf5-xgmq-5525
- org.geoserver:gs-wms (Maven) Vendor— Affected before 2.25.6 Fixed in 2.25.6 Patch available GHSA-fjf5-xgmq-5525
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.26.2, 2.25.6
- Fix · GHSA-fjf5-xgmq-5525 org.geoserver.web:gs-web-app (Maven) Fixed in 2.26.2 Advisory →
- Fix · GHSA-fjf5-xgmq-5525 org.geoserver:gs-wms (Maven) Fixed in 2.26.2 Advisory →
- Fix · GHSA-fjf5-xgmq-5525 org.geoserver.web:gs-web-app (Maven) Fixed in 2.25.6 Advisory →
- Fix · GHSA-fjf5-xgmq-5525 org.geoserver:gs-wms (Maven) Fixed in 2.25.6 Advisory →
Timeline
- 2025-12-11 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2025-58360
- 2026-10-03 Alias added: GHSA-fjf5-xgmq-5525
References
Advisory 2
More Geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
- TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
- TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
- TI-2024-16266 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat CVSS 3.1HIGH 7.5
Sources
- CVE-2025-58360 · CVE Program
- CVE-2025-58360 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-fjf5-xgmq-5525 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences