Unfiltered SQL Injection Vulnerabilities in Geoserver
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages. Users are advised to upgrade to either version 2.21.4, or version 2.22.2 to resolve this issue. Users unable to upgrade should disable the PostGIS Datastore *encode functions* setting to mitigate ``strEndsWith``, ``strStartsWith`` and ``PropertyIsLike `` misuse and enable the PostGIS DataStore *preparedStatements* setting to mitigate the ``FeatureId`` misuse.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | 2.22.0 to before 2.22.2; before 2.21.4 | 2.22.2, 2.21.4 | Patch available | CNA |
| — | org.geoserver.community:gs-jdbcconfig (Maven) | before 2.21.4 | 2.21.4 | Patch available | GHSA-7g5f-wrx8-5ccf |
| — | org.geoserver.community:gs-jdbcconfig (Maven) | 2.22.0 to before 2.22.2 | 2.22.2 | Patch available | GHSA-7g5f-wrx8-5ccf |
- geoserver Vendorgeoserver Affected 2.22.0 to before 2.22.2; before 2.21.4 Fixed in 2.22.2, 2.21.4 Patch available CNA
- org.geoserver.community:gs-jdbcconfig (Maven) Vendor— Affected before 2.21.4 Fixed in 2.21.4 Patch available GHSA-7g5f-wrx8-5ccf
- org.geoserver.community:gs-jdbcconfig (Maven) Vendor— Affected 2.22.0 to before 2.22.2 Fixed in 2.22.2 Patch available GHSA-7g5f-wrx8-5ccf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* | before 2.18.7; 2.19.0 to before 2.19.7; 2.20.0 to before 2.20.7; 2.21.0 to before 2.21.4; 2.22.0 to before 2.22.2 | Vulnerable | OSGeo |
- cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* Versions before 2.18.7; 2.19.0 to before 2.19.7; 2.20.0 to before 2.20.7; 2.21.0 to before 2.21.4; 2.22.0 to before 2.22.2 Vulnerable ·OSGeo
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.22.2, 2.21.4
- Fix · GHSA-7g5f-wrx8-5ccf org.geoserver.community:gs-jdbcconfig (Maven) Fixed in 2.21.4 Advisory →
- Fix · GHSA-7g5f-wrx8-5ccf org.geoserver.community:gs-jdbcconfig (Maven) Fixed in 2.22.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25157
- 2026-10-03 Alias added: GHSA-7g5f-wrx8-5ccf
References
More geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
- TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
Sources
- CVE-2023-25157 · CVE Program
- CVE-2023-25157 · NVD
- FIRST EPSS
- GHSA-7g5f-wrx8-5ccf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences