Read the docs
TI-2022-16471 Aliases CVE-2022-36046GHSA-wff4-fpwg-qqv3

Unexpected server crash in Next.js version 12.2.3

Priority LOW 26CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.

Summary

Next.js is a React framework that can provide building blocks to create web applications. All of the following must be true to be affected by this CVE: Next.js version 12.2.3, Node.js version above v15.0.0 being used with strict `unhandledRejection` exiting AND using next start or a [custom server](https://nextjs.org/docs/advanced-features/custom-server). Deployments on Vercel ([vercel.com](https://vercel.com/)) are not affected along with similar environments where `next-server` isn't being shared across requests.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01185 68th percentileScored 2026-11-07
Fix Fixed next (npm): 12.2.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vercelnext.js= 12.2.3—No fix listedCNA
—next (npm)12.2.3 to before 12.2.412.2.4Patch availableGHSA-wff4-fpwg-qqv3
  • next.js Vendorvercel Affected = 12.2.3 Fixed in — No fix listed CNA
  • next (npm) Vendor— Affected 12.2.3 to before 12.2.4 Fixed in 12.2.4 Patch available GHSA-wff4-fpwg-qqv3

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:vercel:next.js:12.2.3:*:*:*:*:node.js:*:*12.2.3Vulnerablevercel
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*15.0.0Running onNodeJS
  • cpe:2.3:a:vercel:next.js:12.2.3:*:*:*:*:node.js:*:* Versions 12.2.3 Vulnerable ·vercel
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 15.0.0 Running on ·NodeJS

Remediation

  • Fix · GHSA-wff4-fpwg-qqv3 next (npm) Fixed in 12.2.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-36046
  2. 2026-10-03 Alias added: GHSA-wff4-fpwg-qqv3

References

  • TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
  • TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
  • TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
  • TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
  • TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
See all 62 →

Sources