Read the docs
TI-2022-16996 Aliases CVE-2022-36746GHSA-325v-g5vx-whxc

LibreNMS v22.6.0 was discovered to contain a cross-site scripting (XSS) vulnerability via…

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

LibreNMS v22.6.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the component oxidized-cfg-check.inc.php.

Why it matters now

EPSS 0.00507 43rd percentileScored 2026-11-07
Fix Fixed librenms/librenms (Packagist): 22.7.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—librenms/librenms (Packagist)before 22.7.022.7.0Patch availableGHSA-325v-g5vx-whxc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • librenms/librenms (Packagist) Vendor— Affected before 22.7.0 Fixed in 22.7.0 Patch available GHSA-325v-g5vx-whxc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:22.6.0:*:*:*:*:*:*:*22.6.0Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:22.6.0:*:*:*:*:*:*:* Versions 22.6.0 Vulnerable ·librenms

Remediation

  • Fix · GHSA-325v-g5vx-whxc librenms/librenms (Packagist) Fixed in 22.7.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-36746
  2. 2026-10-03 Alias added: GHSA-325v-g5vx-whxc

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources