Read the docs
TI-2022-22730 Aliases CVE-2022-45968GHSA-4gjr-vgfx-9qvw

Alist v3.4.0 is vulnerable to File Upload.

Priority HIGH 73CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-434.

Summary

Alist v3.4.0 is vulnerable to File Upload. A user with only file upload permission can upload any file to any folder (even a password protected one).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0102 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/alist-org/alist/v3 (Go): 3.5.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—github.com/alist-org/alist/v3 (Go)before 3.5.13.5.1Patch availableGHSA-4gjr-vgfx-9qvw
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • github.com/alist-org/alist/v3 (Go) Vendor— Affected before 3.5.1 Fixed in 3.5.1 Patch available GHSA-4gjr-vgfx-9qvw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:alistgo:alist:3.4.0:*:*:*:*:*:*:*3.4.0VulnerableAlistGo
  • cpe:2.3:a:alistgo:alist:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·AlistGo

Remediation

  • Fix · GHSA-4gjr-vgfx-9qvw github.com/alist-org/alist/v3 (Go) Fixed in 3.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-45968
  2. 2026-10-03 Alias added: GHSA-4gjr-vgfx-9qvw

References

  • TI-2022-22731 Alist v3.4.0 is vulnerable to Directory Traversal, CVSS 3.1CRITICAL 9.8
  • TI-2023-15192 AList 3.15.1 is vulnerable to Incorrect Access Control, which can be exploited by… CVSS 3.1HIGH 7.5
  • TI-2022-22732 Alist v3.5.1 is vulnerable to Cross Site Scripting (XSS) via the bulletin board. CVSS 3.1MEDIUM 5.4
  • TI-2024-31449 Alist Contains a Reflected Cross-Site Scripting Vulnerability CVSS 4.0MEDIUM 5.1
  • TI-2026-20320 Alist has Insecure TLS Config CVSS 3.1CRITICAL 9.1
  • TI-2026-20321 Alist vulnerable to Path Traversal in multiple file operation handlers CVSS 3.1HIGH 8.8
See all 8 →

Sources