Alist Contains a Reflected Cross-Site Scripting Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
AList is a file list program that supports multiple storages. AList contains a reflected cross-site scripting vulnerability in helper.go. The endpoint /i/:link_name takes in a user-provided value and reflects it back in the response. The endpoint returns an application/xml response, opening it up to HTML tags via XHTML and thus leading to a XSS vulnerability. This vulnerability is fixed in 3.29.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| alist-org | alist | before 3.29.0 | 3.29.0 | Patch available | CNA |
| — | github.com/alist-org/alist/v3 (Go) | before 3.29.0 | 3.29.0 | Patch available | GHSA-8pph-gfhp-w226 |
- alist Vendoralist-org Affected before 3.29.0 Fixed in 3.29.0 Patch available CNA
- github.com/alist-org/alist/v3 (Go) Vendor— Affected before 3.29.0 Fixed in 3.29.0 Patch available GHSA-8pph-gfhp-w226
Remediation
- Fix · CNA alist (alist-org) Fixed in 3.29.0
- Fix · GHSA-8pph-gfhp-w226 github.com/alist-org/alist/v3 (Go) Fixed in 3.29.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47067
- 2026-10-03 Alias added: GHSA-8pph-gfhp-w226
References
Advisory 2
More AlistGo Alist vulnerabilities
- TI-2022-22731 Alist v3.4.0 is vulnerable to Directory Traversal, CVSS 3.1CRITICAL 9.8
- TI-2022-22730 Alist v3.4.0 is vulnerable to File Upload. CVSS 3.1HIGH 8.8
- TI-2023-15192 AList 3.15.1 is vulnerable to Incorrect Access Control, which can be exploited by… CVSS 3.1HIGH 7.5
- TI-2022-22732 Alist v3.5.1 is vulnerable to Cross Site Scripting (XSS) via the bulletin board. CVSS 3.1MEDIUM 5.4
- TI-2026-20320 Alist has Insecure TLS Config CVSS 3.1CRITICAL 9.1
- TI-2026-20321 Alist vulnerable to Path Traversal in multiple file operation handlers CVSS 3.1HIGH 8.8
Sources
- CVE-2024-47067 · CVE Program
- CVE-2024-47067 · NVD
- FIRST EPSS
- GHSA-8pph-gfhp-w226 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences