Read the docs
TI-2022-22731 Aliases CVE-2022-45969GHSA-pmg2-rph8-p8r6

Alist v3.4.0 is vulnerable to Directory Traversal,

Priority HIGH 82CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Alist v3.4.0 is vulnerable to Directory Traversal,

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01232 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/alist-org/alist/v3 (Go): 3.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—github.com/alist-org/alist/v3 (Go)before 3.6.03.6.0Patch availableGHSA-pmg2-rph8-p8r6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • github.com/alist-org/alist/v3 (Go) Vendor— Affected before 3.6.0 Fixed in 3.6.0 Patch available GHSA-pmg2-rph8-p8r6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:alistgo:alist:3.4.0:*:*:*:*:*:*:*3.4.0VulnerableAlistGo
  • cpe:2.3:a:alistgo:alist:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·AlistGo

Remediation

  • Fix · GHSA-pmg2-rph8-p8r6 github.com/alist-org/alist/v3 (Go) Fixed in 3.6.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-45969
  2. 2026-10-03 Alias added: GHSA-pmg2-rph8-p8r6

References

  • TI-2022-22730 Alist v3.4.0 is vulnerable to File Upload. CVSS 3.1HIGH 8.8
  • TI-2023-15192 AList 3.15.1 is vulnerable to Incorrect Access Control, which can be exploited by… CVSS 3.1HIGH 7.5
  • TI-2022-22732 Alist v3.5.1 is vulnerable to Cross Site Scripting (XSS) via the bulletin board. CVSS 3.1MEDIUM 5.4
  • TI-2024-31449 Alist Contains a Reflected Cross-Site Scripting Vulnerability CVSS 4.0MEDIUM 5.1
  • TI-2026-20320 Alist has Insecure TLS Config CVSS 3.1CRITICAL 9.1
  • TI-2026-20321 Alist vulnerable to Path Traversal in multiple file operation handlers CVSS 3.1HIGH 8.8
See all 8 →

Sources