Alist has Insecure TLS Config
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Alist is a file list program that supports multiple storages, powered by Gin and Solidjs. Prior to version 3.57.0, the application disables TLS certificate verification by default for all outgoing storage driver communications, making the system vulnerable to Man-in-the-Middle (MitM) attacks. This enables the complete decryption, theft, and manipulation of all data transmitted during storage operations, severely compromising the confidentiality and integrity of user data. This issue has been patched in version 3.57.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AlistGo | alist | before 3.57.0 | 3.57.0 | Patch available | CNA |
| — | github.com/alist-org/alist/v3 (Go) | before 3.57.0 | 3.57.0 | Patch available | GHSA-8jmm-3xwx-w974 |
- alist VendorAlistGo Affected before 3.57.0 Fixed in 3.57.0 Patch available CNA
- github.com/alist-org/alist/v3 (Go) Vendor— Affected before 3.57.0 Fixed in 3.57.0 Patch available GHSA-8jmm-3xwx-w974
Remediation
- Fix · CNA alist (AlistGo) Fixed in 3.57.0
- Fix · GHSA-8jmm-3xwx-w974 github.com/alist-org/alist/v3 (Go) Fixed in 3.57.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25160
- 2026-10-03 Alias added: GHSA-8jmm-3xwx-w974
References
More AlistGo Alist vulnerabilities
- TI-2022-22731 Alist v3.4.0 is vulnerable to Directory Traversal, CVSS 3.1CRITICAL 9.8
- TI-2022-22730 Alist v3.4.0 is vulnerable to File Upload. CVSS 3.1HIGH 8.8
- TI-2023-15192 AList 3.15.1 is vulnerable to Incorrect Access Control, which can be exploited by… CVSS 3.1HIGH 7.5
- TI-2022-22732 Alist v3.5.1 is vulnerable to Cross Site Scripting (XSS) via the bulletin board. CVSS 3.1MEDIUM 5.4
- TI-2024-31449 Alist Contains a Reflected Cross-Site Scripting Vulnerability CVSS 4.0MEDIUM 5.1
- TI-2026-20321 Alist vulnerable to Path Traversal in multiple file operation handlers CVSS 3.1HIGH 8.8
Sources
- CVE-2026-25160 · CVE Program
- CVE-2026-25160 · NVD
- FIRST EPSS
- GHSA-8jmm-3xwx-w974 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences