Cross-site Scripting (XSS) - Generic in librenms/librenms
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - Generic in GitHub repository librenms/librenms prior to 23.9.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0069 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (librenms): 23.9.0librenms/librenms (Packagist): 23.9.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms/librenms | before 23.9.0 | 23.9.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 23.9.0 | 23.9.0 | Patch available | GHSA-qxrq-376q-p39h |
- librenms/librenms Vendorlibrenms Affected before 23.9.0 Fixed in 23.9.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 23.9.0 Fixed in 23.9.0 Patch available GHSA-qxrq-376q-p39h
Remediation
- Fix · CNA librenms/librenms (librenms) Fixed in 23.9.0
- Fix · GHSA-qxrq-376q-p39h librenms/librenms (Packagist) Fixed in 23.9.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
librenms/librenms 23.9.0
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2023-04583 Cross-site Scripting (XSS) - DOM in librenms/librenmsPriority LOW 30
- TI-2023-04587 Cross-site Scripting (XSS) - Stored in librenms/librenmsPriority LOW 28
- TI-2023-04586 Cross-site Scripting (XSS) - DOM in librenms/librenmsPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4980
- 2026-10-03 Alias added: GHSA-qxrq-376q-p39h
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-4980 · CVE Program
- CVE-2023-4980 · NVD
- FIRST EPSS
- GHSA-qxrq-376q-p39h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences