Read the docs
TI-2023-04660 Aliases CVE-2023-5060GHSA-2q8c-gqf4-mg3v

Cross-site Scripting (XSS) - DOM in librenms/librenms

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site Scripting (XSS) - DOM in GitHub repository librenms/librenms prior to 23.9.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00642 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (librenms): 23.9.1librenms/librenms (Packagist): 23.9.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenms/librenmsbefore 23.9.123.9.1Patch availableCNA
—librenms/librenms (Packagist)before 23.9.123.9.1Patch availableGHSA-2q8c-gqf4-mg3v
  • librenms/librenms Vendorlibrenms Affected before 23.9.1 Fixed in 23.9.1 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected before 23.9.1 Fixed in 23.9.1 Patch available GHSA-2q8c-gqf4-mg3v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*before 23.9.1Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions before 23.9.1 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms/librenms (librenms) Fixed in 23.9.1
  • Fix · GHSA-2q8c-gqf4-mg3v librenms/librenms (Packagist) Fixed in 23.9.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5060
  2. 2026-10-03 Alias added: GHSA-2q8c-gqf4-mg3v
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources