Read the docs
TI-2023-05147 Aliases CVE-2023-5591GHSA-mr6h-7x2m-rgmq

SQL Injection in librenms/librenms

Priority MEDIUM 62CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

SQL Injection in GitHub repository librenms/librenms prior to 23.10.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.23762 97th percentileScored 2026-11-07
Fix Fixed librenms/librenms (librenms): 23.10.0librenms/librenms (Packagist): 23.10.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenms/librenmsbefore 23.10.023.10.0Patch availableCNA
—librenms/librenms (Packagist)before 23.10.023.10.0Patch availableGHSA-mr6h-7x2m-rgmq
  • librenms/librenms Vendorlibrenms Affected before 23.10.0 Fixed in 23.10.0 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected before 23.10.0 Fixed in 23.10.0 Patch available GHSA-mr6h-7x2m-rgmq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*up to 23.9.1Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions up to 23.9.1 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms/librenms (librenms) Fixed in 23.10.0
  • Fix · GHSA-mr6h-7x2m-rgmq librenms/librenms (Packagist) Fixed in 23.10.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5591
  2. 2026-10-03 Alias added: GHSA-mr6h-7x2m-rgmq

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources