EazyDocs < 2.3.6 - Unauthenticated Arbitrary Posts Deletion and Document Management
Priority HIGH 72CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
The EazyDocs WordPress plugin before 2.3.6 does not have authorization and CSRF checks when handling documents and does not ensure that they are documents from the plugin, allowing unauthenticated users to delete arbitrary posts, as well as add and delete documents/sections.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00248 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed EazyDocs (Unknown): 2.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | EazyDocs | before 2.3.6 | 2.3.6 | Patch available | CNA |
- EazyDocs VendorUnknown Affected before 2.3.6 Fixed in 2.3.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* | before 2.3.6 | Vulnerable | Spider Themes |
- cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* Versions before 2.3.6 Vulnerable ·Spider Themes
Remediation
- Fix · CNA EazyDocs (Unknown) Fixed in 2.3.6
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6029
- 2026-10-03 Alias added: GHSA-2c3v-6gcr-6f8h
References
More Spider Themes Eazydocs vulnerabilities
- TI-2024-03731 EazyDocs < 2.5.0 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-00223 EazyDocs < 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management CVSS 3.1MEDIUM 4.3
- TI-2023-05557 EazyDocs < 2.3.4 - Subscriber + SQLi CVSS 3.1HIGH 8.8
- TI-2023-25718 WordPress EazyDocs Plugin <= 2.3.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.8
Sources
- CVE-2023-6029 · CVE Program
- CVE-2023-6029 · NVD
- FIRST EPSS
- GHSA-2c3v-6gcr-6f8h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences