EazyDocs < 2.3.4 - Subscriber + SQLi
Priority MEDIUM 40CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The EazyDocs WordPress plugin before 2.3.4 does not properly sanitize and escape "data" parameter before using it in an SQL statement via an AJAX action, which could allow any authenticated users, such as subscribers, to perform SQL Injection attacks.
Why it matters now
EPSS 0.00853 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed EazyDocs (Unknown): 2.3.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | EazyDocs | before 2.3.4 | 2.3.4 | Patch available | CNA |
- EazyDocs VendorUnknown Affected before 2.3.4 Fixed in 2.3.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* | before 2.3.4 | Vulnerable | Spider Themes |
- cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* Versions before 2.3.4 Vulnerable ·Spider Themes
Remediation
- Fix · CNA EazyDocs (Unknown) Fixed in 2.3.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6035
- 2026-10-03 Alias added: GHSA-gf95-rw86-w2vf
References
More Spider Themes Eazydocs vulnerabilities
- TI-2023-05553 EazyDocs < 2.3.6 - Unauthenticated Arbitrary Posts Deletion and Document Management CVSS 3.1HIGH 7.5
- TI-2024-03731 EazyDocs < 2.5.0 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-00223 EazyDocs < 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management CVSS 3.1MEDIUM 4.3
- TI-2023-25718 WordPress EazyDocs Plugin <= 2.3.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.8
Sources
- CVE-2023-6035 · CVE Program
- CVE-2023-6035 · NVD
- FIRST EPSS
- GHSA-gf95-rw86-w2vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences