EazyDocs < 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management
Priority MEDIUM 53Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The EazyDocs WordPress plugin before 2.4.0 re-introduced CVE-2023-6029 (https://wpscan.com/vulnerability/7a0aaf85-8130-4fd7-8f09-f8edc929597e/) in 2.3.8, allowing any authenticated users, such as subscriber to delete arbitrary posts, as well as add and delete documents/sections. The issue was partially fixed in 2.3.9.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00424 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed EazyDocs (Unknown): 2.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | EazyDocs | 2.3.8 to before 2.4.0 | 2.4.0 | Patch available | CNA |
- EazyDocs VendorUnknown Affected 2.3.8 to before 2.4.0 Fixed in 2.4.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* | before 2.4.0 | Vulnerable | Spider Themes |
- cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* Versions before 2.4.0 Vulnerable ·Spider Themes
Remediation
- Fix · CNA EazyDocs (Unknown) Fixed in 2.4.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0248
- 2026-10-03 Alias added: GHSA-xmp6-3vj6-r6rw
References
More Spider Themes Eazydocs vulnerabilities
- TI-2023-05553 EazyDocs < 2.3.6 - Unauthenticated Arbitrary Posts Deletion and Document Management CVSS 3.1HIGH 7.5
- TI-2024-03731 EazyDocs < 2.5.0 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-05557 EazyDocs < 2.3.4 - Subscriber + SQLi CVSS 3.1HIGH 8.8
- TI-2023-25718 WordPress EazyDocs Plugin <= 2.3.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.8
Sources
- CVE-2024-0248 · CVE Program
- CVE-2024-0248 · NVD
- FIRST EPSS
- GHSA-xmp6-3vj6-r6rw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences