Read the docs
TI-2024-03731 Aliases CVE-2024-3999GHSA-mrvh-699v-65gr

EazyDocs < 2.5.0 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The EazyDocs WordPress plugin before 2.5.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00397 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed EazyDocs (Unknown): 2.5.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownEazyDocs before 2.5.02.5.0Patch availableCNA
  • EazyDocs VendorUnknown Affected before 2.5.0 Fixed in 2.5.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:*before 2.5.0VulnerableSpider Themes
  • cpe:2.3:a:spider-themes:eazydocs:*:*:*:*:*:wordpress:*:* Versions before 2.5.0 Vulnerable ·Spider Themes

Remediation

  • Fix · CNA EazyDocs (Unknown) Fixed in 2.5.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3999
  2. 2026-10-03 Alias added: GHSA-mrvh-699v-65gr

References

  • TI-2023-05553 EazyDocs < 2.3.6 - Unauthenticated Arbitrary Posts Deletion and Document Management CVSS 3.1HIGH 7.5
  • TI-2024-00223 EazyDocs < 2.4.0 - Subscriber+ Arbitrary Posts Deletion and Document Management CVSS 3.1MEDIUM 4.3
  • TI-2023-05557 EazyDocs < 2.3.4 - Subscriber + SQLi CVSS 3.1HIGH 8.8
  • TI-2023-25718 WordPress EazyDocs Plugin <= 2.3.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.8

Sources