Information disclosure in Atlassian Confluence Data Center
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
Affected versions of Atlassian Confluence Server and Data Center allow anonymous remote attackers to view the names of attachments and labels in a private Confluence space. This occurs via an Information Disclosure vulnerability in the macro preview feature. This vulnerability was reported by Rojan Rijal of the Tinder Security Engineering team. The affected versions are before version 7.13.15, from version 7.14.0 before 7.19.7, and from version 7.20.0 before 8.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 7.20.2 | < 7.20.2, >= 7.13.5, >= 7.19.7, >= 8.20.0 | Patch available | CNA |
| Atlassian | Confluence Server | >= 7.20.2 | < 7.20.2, >= 7.13.5, >= 7.19.7, >= 8.20.0 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 7.20.2 Fixed in < 7.20.2, >= 7.13.5, >= 7.19.7, >= 8.20.0 Patch available CNA
- Confluence Server VendorAtlassian Affected >= 7.20.2 Fixed in < 7.20.2, >= 7.13.5, >= 7.19.7, >= 8.20.0 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | before 7.13.15; 7.14.0 to before 7.19.7; 7.20.0 to before 8.2.0 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | before 7.13.15; 7.14.0 to before 7.19.7; 7.20.0 to before 8.2.0 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions before 7.13.15; 7.14.0 to before 7.19.7; 7.20.0 to before 8.2.0 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions before 7.13.15; 7.14.0 to before 7.19.7; 7.20.0 to before 8.2.0 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 7.20.2, >= 7.13.5, >= 7.19.7, >= 8.20.0
- Fix · CNA Confluence Server (Atlassian) Fixed in < 7.20.2, >= 7.13.5, >= 7.19.7, >= 8.20.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22503
- 2026-10-03 Alias added: GHSA-7823-23gq-8g79
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-22503 · CVE Program
- CVE-2023-22503 · NVD
- FIRST EPSS
- GHSA-7823-23gq-8g79 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences