Unrestricted file upload in Atlassian Confluence Data Center
Priority LOW 30CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
Affected versions of Atlassian Confluence Server allow remote attackers who have read permissions to a page, but not write permissions, to upload attachments via a Broken Access Control vulnerability in the attachments feature.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00747 55th percentileScored 2026-11-07
Fix Fixed Confluence Data Center (Atlassian): < 1.1.2, >= 7.13.7, >= 7.19.9 +2Confluence Server (Atlassian): < 1.1.2, >= 7.13.7, >= 7.19.9 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 1.1.2; >= 7.14.0; >= 7.20.0 | < 1.1.2, >= 7.13.7, >= 7.19.9, >= 8.2.2, >= 8.3.0 | Patch available | CNA |
| Atlassian | Confluence Server | >= 1.1.2; >= 7.14.0; >= 7.20.0 | < 1.1.2, >= 7.13.7, >= 7.19.9, >= 8.2.2, >= 8.3.0 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 1.1.2; >= 7.14.0; >= 7.20.0 Fixed in < 1.1.2, >= 7.13.7, >= 7.19.9, >= 8.2.2, >= 8.3.0 Patch available CNA
- Confluence Server VendorAtlassian Affected >= 1.1.2; >= 7.14.0; >= 7.20.0 Fixed in < 1.1.2, >= 7.13.7, >= 7.19.9, >= 8.2.2, >= 8.3.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | before 7.13.17; 7.14.0 to before 7.19.9; 7.20.0 to before 8.2.2 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions before 7.13.17; 7.14.0 to before 7.19.9; 7.20.0 to before 8.2.2 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 1.1.2, >= 7.13.7, >= 7.19.9, >= 8.2.2, >= 8.3.0
- Fix · CNA Confluence Server (Atlassian) Fixed in < 1.1.2, >= 7.13.7, >= 7.19.9, >= 8.2.2, >= 8.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22504
- 2026-10-03 Alias added: GHSA-hfhf-22gm-76w3
References
More Atlassian Confluence Server vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2019-02554 Path traversal in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-22504 · CVE Program
- CVE-2023-22504 · NVD
- FIRST EPSS
- GHSA-hfhf-22gm-76w3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences