Read the docs
TI-2023-08751 Aliases CVE-2023-22505GHSA-78hc-mph9-mhfm

This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22505 was…

Priority MEDIUM 44Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22505 was introduced in version 8.0.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to latest version. If you're unable to upgrade to latest, upgrade to one of these fixed versions: 8.3.2, 8.4.0. See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html).|https://confluence.atlassian.com/doc/confluence-release-notes-327.html).] You can download the latest version of Confluence Data Center & Server from the download center ([https://www.atlassian.com/software/confluence/download-archives).|https://www.atlassian.com/software/confluence/download-archives).] This vulnerability was discovered by a private user and reported via our Bug Bounty program.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02057 81st percentileScored 2026-11-07
Fix Fixed Confluence Data Center (Atlassian): < 8.0.0, >= 8.3.2, >= 8.4.0Confluence Server (Atlassian): < 8.0.0, >= 8.3.2, >= 8.4.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianConfluence Data Center>= 8.0.0< 8.0.0, >= 8.3.2, >= 8.4.0Patch availableCNA
AtlassianConfluence Server>= 8.0.0< 8.0.0, >= 8.3.2, >= 8.4.0Patch availableCNA
  • Confluence Data Center VendorAtlassian Affected >= 8.0.0 Fixed in < 8.0.0, >= 8.3.2, >= 8.4.0 Patch available CNA
  • Confluence Server VendorAtlassian Affected >= 8.0.0 Fixed in < 8.0.0, >= 8.3.2, >= 8.4.0 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*8.0.0 to before 8.3.2VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*8.0.0 to before 8.3.2VulnerableAtlassian
  • cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.3.2 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.3.2 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Confluence Data Center (Atlassian) Fixed in < 8.0.0, >= 8.3.2, >= 8.4.0
  • Fix · CNA Confluence Server (Atlassian) Fixed in < 8.0.0, >= 8.3.2, >= 8.4.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-22505
  2. 2026-10-03 Alias added: GHSA-78hc-mph9-mhfm

References

  • TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
See all 38 →

Sources