This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22508 was…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22508 was introduced in version 6.1.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to avoid this bug using the following options: * Upgrade to a Confluence feature release greater than or equal to 8.2.0 (ie: 8.2, 8.2, 8.4, etc...) * Upgrade to a Confluence 7.19 LTS bugfix release greater than or equal to 7.19.8 (ie: 7.19.8, 7.19.9, 7.19.10, 7.19.11, etc...) * Upgrade to a Confluence 7.13 LTS bugfix release greater than or equal to 7.13.20 (Release available early August) See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Data Center & Server from the download center (https://www.atlassian.com/software/confluence/download-archives ). If you are unable to upgrade your instance please use the following guide to workaround the issue https://confluence.atlassian.com/confkb/how-to-disable-the-jmx-network-port-for-cve-2023-22508-1267761550.html This vulnerability was discovered by a private user and reported via our Bug Bounty program.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 6.1.0 | < 6.1.0, >= 7.19.8, >= 8.2.0 | Patch available | CNA |
| Atlassian | Confluence Server | >= 6.1.0 | < 6.1.0, >= 7.19.8, >= 8.2.0 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 6.1.0 Fixed in < 6.1.0, >= 7.19.8, >= 8.2.0 Patch available CNA
- Confluence Server VendorAtlassian Affected >= 6.1.0 Fixed in < 6.1.0, >= 7.19.8, >= 8.2.0 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | 6.1.0 to before 7.13.20; 7.14.0 to before 7.19.8; 7.20.0 to before 8.2.0 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | 6.1.0 to before 7.13.20; 7.14.0 to before 7.19.8; 7.20.0 to before 8.2.0 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 6.1.0 to before 7.13.20; 7.14.0 to before 7.19.8; 7.20.0 to before 8.2.0 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 6.1.0 to before 7.13.20; 7.14.0 to before 7.19.8; 7.20.0 to before 8.2.0 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 6.1.0, >= 7.19.8, >= 8.2.0
- Fix · CNA Confluence Server (Atlassian) Fixed in < 6.1.0, >= 7.19.8, >= 8.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22508
- 2026-10-03 Alias added: GHSA-jq45-hqc5-f722
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-22508 · CVE Program
- CVE-2023-22508 · NVD
- FIRST EPSS
- GHSA-jq45-hqc5-f722 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences