Injection in Atlassian Confluence Data Center
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
This Template Injection vulnerability allows an authenticated attacker, including one with anonymous access, to inject unsafe user input into a Confluence page. Using this approach, an attacker is able to achieve Remote Code Execution (RCE) on an affected instance. Publicly accessible Confluence Data Center and Server versions as listed below are at risk and require immediate attention. See the advisory for additional details Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 4.0.0; >= 7.20.0; >= 8.0.0; >= 8.6.0 | < 4.0.0, >= 7.19.17, >= 8.4.5, >= 8.5.4, >= 8.6.2, >= 8.7.1 | Patch available | CNA |
| Atlassian | Confluence Server | >= 4.0.0; >= 7.20.0; >= 8.0.0; >= 8.6.0 | < 4.0.0, >= 7.19.17, >= 8.4.5, >= 8.5.4, >= 8.6.2, >= 8.7.1 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 4.0.0; >= 7.20.0; >= 8.0.0; >= 8.6.0 Fixed in < 4.0.0, >= 7.19.17, >= 8.4.5, >= 8.5.4, >= 8.6.2, >= 8.7.1 Patch available CNA
- Confluence Server VendorAtlassian Affected >= 4.0.0; >= 7.20.0; >= 8.0.0; >= 8.6.0 Fixed in < 4.0.0, >= 7.19.17, >= 8.4.5, >= 8.5.4, >= 8.6.2, >= 8.7.1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | 4.0 to before 7.19.17; 8.0.0 to before 8.4.5; 8.5.0 to before 8.5.4; 8.6.0 to before 8.6.2 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_data_center:8.7.0:*:*:*:*:*:*:* | 8.7.0 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | 4.0 to before 7.19.17; 8.0.0 to before 8.4.5; 8.5.0 to before 8.5.4 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 4.0 to before 7.19.17; 8.0.0 to before 8.4.5; 8.5.0 to before 8.5.4; 8.6.0 to before 8.6.2 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_data_center:8.7.0:*:*:*:*:*:*:* Versions 8.7.0 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 4.0 to before 7.19.17; 8.0.0 to before 8.4.5; 8.5.0 to before 8.5.4 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 4.0.0, >= 7.19.17, >= 8.4.5, >= 8.5.4, >= 8.6.2, >= 8.7.1
- Fix · CNA Confluence Server (Atlassian) Fixed in < 4.0.0, >= 7.19.17, >= 8.4.5, >= 8.5.4, >= 8.6.2, >= 8.7.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22522
- 2026-10-03 Alias added: GHSA-rcjw-44p8-ppj6
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-22522 · CVE Program
- CVE-2023-22522 · NVD
- FIRST EPSS
- GHSA-rcjw-44p8-ppj6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences