Code injection in Atlassian Confluence Data Center
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
This High severity RCE (Remote Code Execution) vulnerability was introduced in version 7.19.0 of Confluence Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.2, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 7.19: Upgrade to a release 7.19.17, or any higher 7.19.x release Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was discovered by m1sn0w and reported via our Bug Bounty program
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 7.13.0; >= 7.19.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1 | < 7.13.0, >= 7.19.17, >= 8.5.5, >= 8.7.2 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 7.13.0; >= 7.19.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1 Fixed in < 7.13.0, >= 7.19.17, >= 8.5.5, >= 8.7.2 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | 7.19.0 to before 7.19.17; 8.5.0 to before 8.5.5; 8.7.0 to before 8.7.2 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | 7.19 to before 7.19.17; 8.5.0 to before 8.5.5; 8.7.0 – 8.7.2 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 7.19.0 to before 7.19.17; 8.5.0 to before 8.5.5; 8.7.0 to before 8.7.2 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 7.19 to before 7.19.17; 8.5.0 to before 8.5.5; 8.7.0 – 8.7.2 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 7.13.0, >= 7.19.17, >= 8.5.5, >= 8.7.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22526
- 2026-10-03 Alias added: GHSA-f9mv-753f-hvx4
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-22526 · CVE Program
- CVE-2023-22526 · NVD
- FIRST EPSS
- GHSA-f9mv-753f-hvx4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences