Read the docs
TI-2023-10999 Aliases CVE-2023-25727GHSA-6hr3-44gx-g6wh

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS…

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01163 67th percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.9.11, 5.2.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmyadmin/phpmyadmin (Packagist)4.3.0 to before 4.9.114.9.11Patch availableGHSA-6hr3-44gx-g6wh
—phpmyadmin/phpmyadmin (Packagist)5.0 to before 5.2.15.2.1Patch availableGHSA-6hr3-44gx-g6wh
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.3.0 to before 4.9.11 Fixed in 4.9.11 Patch available GHSA-6hr3-44gx-g6wh
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 5.0 to before 5.2.1 Fixed in 5.2.1 Patch available GHSA-6hr3-44gx-g6wh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*before 4.9.11; 5.0.0 to before 5.2.1VulnerablephpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions before 4.9.11; 5.0.0 to before 5.2.1 Vulnerable ·phpMyAdmin

Remediation

  • Fix · GHSA-6hr3-44gx-g6wh phpmyadmin/phpmyadmin (Packagist) Fixed in 4.9.11 Advisory →
  • Fix · GHSA-6hr3-44gx-g6wh phpmyadmin/phpmyadmin (Packagist) Fixed in 5.2.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-25727
  2. 2026-10-03 Alias added: GHSA-6hr3-44gx-g6wh

References

  • TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
  • TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
  • TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
  • TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
  • TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
See all 276 →

Sources