contao/core-bundle has path traversal vulnerability in the file manager
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Contao is an open source content management system. Prior to versions 4.9.40, 4.13.21, and 5.1.4, logged in users can list arbitrary system files in the file manager by manipulating the Ajax request. However, it is not possible to read the contents of these files. Users should update to Contao 4.9.40, 4.13.21 or 5.1.4 to receive a patch. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contao | contao | 2.0.0 to before 4.9.40; 4.10.0 to before 4.13.21; 5.0.0 to before 5.1.4 | 4.9.40, 4.13.21, 5.1.4 | Patch available | CNA |
| — | contao/contao (Packagist) | 4.9.0 to before 4.9.40 | 4.9.40 | Patch available | GHSA-fp7q-xhhw-6rj3 |
| — | contao/contao (Packagist) | 4.13.0 to before 4.13.21 | 4.13.21 | Patch available | GHSA-fp7q-xhhw-6rj3 |
| — | contao/contao (Packagist) | 5.1.0 to before 5.1.4 | 5.1.4 | Patch available | GHSA-fp7q-xhhw-6rj3 |
- contao Vendorcontao Affected 2.0.0 to before 4.9.40; 4.10.0 to before 4.13.21; 5.0.0 to before 5.1.4 Fixed in 4.9.40, 4.13.21, 5.1.4 Patch available CNA
- contao/contao (Packagist) Vendor— Affected 4.9.0 to before 4.9.40 Fixed in 4.9.40 Patch available GHSA-fp7q-xhhw-6rj3
- contao/contao (Packagist) Vendor— Affected 4.13.0 to before 4.13.21 Fixed in 4.13.21 Patch available GHSA-fp7q-xhhw-6rj3
- contao/contao (Packagist) Vendor— Affected 5.1.0 to before 5.1.4 Fixed in 5.1.4 Patch available GHSA-fp7q-xhhw-6rj3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 2.0 to before 4.9.40; 4.10.0 to before 4.13.21; 5.0.0 to before 5.1.4 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 2.0 to before 4.9.40; 4.10.0 to before 4.13.21; 5.0.0 to before 5.1.4 Vulnerable ·contao
Remediation
- Fix · CNA contao (contao) Fixed in 4.9.40, 4.13.21, 5.1.4
- Fix · GHSA-fp7q-xhhw-6rj3 contao/contao (Packagist) Fixed in 4.9.40 Advisory →
- Fix · GHSA-fp7q-xhhw-6rj3 contao/contao (Packagist) Fixed in 4.13.21 Advisory →
- Fix · GHSA-fp7q-xhhw-6rj3 contao/contao (Packagist) Fixed in 5.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-29200
- 2026-10-03 Alias added: GHSA-fp7q-xhhw-6rj3
References
Advisory 3
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
Sources
- CVE-2023-29200 · CVE Program
- CVE-2023-29200 · NVD
- FIRST EPSS
- GHSA-fp7q-xhhw-6rj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences