Read the docs
TI-2023-17518 Aliases CVE-2023-35042GHSA-59x6-g4jr-4hxc

GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code…

Priority HIGH 78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code via java.lang.Runtime.getRuntime().exec in wps:LiteralData within a wps:Execute request, as exploited in the wild in June 2023. NOTE: the vendor states that they are unable to reproduce this in any version.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.44825 98th percentileScored 2026-11-07
Fix Fixed org.geoserver:gs-wms (Maven): 2.18.6, 2.19.6, 2.20.4org.geoserver:gs-wfs (Maven): 2.18.6, 2.19.6, 2.20.4+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.geoserver:gs-wms (Maven)before 2.18.62.18.6Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wfs (Maven)before 2.18.62.18.6Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wms (Maven)2.19.0 to before 2.19.62.19.6Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wfs (Maven)2.19.0 to before 2.19.62.19.6Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wms (Maven)2.20.0 to before 2.20.42.20.4Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wfs (Maven)2.20.0 to before 2.20.42.20.4Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wps (Maven)before 2.18.62.18.6Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wps (Maven)2.19.0 to before 2.19.62.19.6Patch availableGHSA-59x6-g4jr-4hxc
—org.geoserver:gs-wps (Maven)2.20.0 to before 2.20.42.20.4Patch availableGHSA-59x6-g4jr-4hxc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.geoserver:gs-wms (Maven) Vendor— Affected before 2.18.6 Fixed in 2.18.6 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wfs (Maven) Vendor— Affected before 2.18.6 Fixed in 2.18.6 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wms (Maven) Vendor— Affected 2.19.0 to before 2.19.6 Fixed in 2.19.6 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wfs (Maven) Vendor— Affected 2.19.0 to before 2.19.6 Fixed in 2.19.6 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wms (Maven) Vendor— Affected 2.20.0 to before 2.20.4 Fixed in 2.20.4 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wfs (Maven) Vendor— Affected 2.20.0 to before 2.20.4 Fixed in 2.20.4 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wps (Maven) Vendor— Affected before 2.18.6 Fixed in 2.18.6 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wps (Maven) Vendor— Affected 2.19.0 to before 2.19.6 Fixed in 2.19.6 Patch available GHSA-59x6-g4jr-4hxc
  • org.geoserver:gs-wps (Maven) Vendor— Affected 2.20.0 to before 2.20.4 Fixed in 2.20.4 Patch available GHSA-59x6-g4jr-4hxc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*2.0.0Vulnerablegeoserver
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·geoserver

Remediation

  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wms (Maven) Fixed in 2.18.6 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wfs (Maven) Fixed in 2.18.6 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wms (Maven) Fixed in 2.19.6 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wfs (Maven) Fixed in 2.19.6 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wms (Maven) Fixed in 2.20.4 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wfs (Maven) Fixed in 2.20.4 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wps (Maven) Fixed in 2.18.6 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wps (Maven) Fixed in 2.19.6 Advisory →
  • Fix · GHSA-59x6-g4jr-4hxc org.geoserver:gs-wps (Maven) Fixed in 2.20.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-35042
  2. 2026-10-03 Alias added: GHSA-59x6-g4jr-4hxc

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
  • TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
  • TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
  • TI-2024-16266 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat CVSS 3.1HIGH 7.5
See all 16 →

Sources