Read the docs
TI-2023-28098 Aliases CVE-2023-51444GHSA-9v5q-2gwq-q9hq

GeoServer arbitrary file upload vulnerability in REST Coverage Store API

Priority HIGH 67CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434.

Summary

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. An arbitrary file upload vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with permissions to modify coverage stores through the REST Coverage Store API to upload arbitrary file contents to arbitrary file locations which can lead to remote code execution. Coverage stores that are configured using relative paths use a GeoServer Resource implementation that has validation to prevent path traversal but coverage stores that are configured using absolute paths use a different Resource implementation that does not prevent path traversal. This vulnerability can lead to executing arbitrary code. An administrator with limited privileges could also potentially exploit this to overwrite GeoServer security files and obtain full administrator privileges. Versions 2.23.4 and 2.24.1 contain a fix for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01867 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed geoserver (geoserver): 2.23.4org.geoserver:gs-platform (Maven): 2.23.4, 2.24.1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserverbefore 2.23.4; = 2.24.02.23.4Patch availableCNA
—org.geoserver:gs-platform (Maven)before 2.23.42.23.4Patch availableGHSA-9v5q-2gwq-q9hq
—org.geoserver:gs-restconfig (Maven)before 2.23.42.23.4Patch availableGHSA-9v5q-2gwq-q9hq
—org.geoserver:gs-platform (Maven)2.24.0 to before 2.24.12.24.1Patch availableGHSA-9v5q-2gwq-q9hq
—org.geoserver:gs-restconfig (Maven)2.24.0 to before 2.24.12.24.1Patch availableGHSA-9v5q-2gwq-q9hq
  • geoserver Vendorgeoserver Affected before 2.23.4; = 2.24.0 Fixed in 2.23.4 Patch available CNA
  • org.geoserver:gs-platform (Maven) Vendor— Affected before 2.23.4 Fixed in 2.23.4 Patch available GHSA-9v5q-2gwq-q9hq
  • org.geoserver:gs-restconfig (Maven) Vendor— Affected before 2.23.4 Fixed in 2.23.4 Patch available GHSA-9v5q-2gwq-q9hq
  • org.geoserver:gs-platform (Maven) Vendor— Affected 2.24.0 to before 2.24.1 Fixed in 2.24.1 Patch available GHSA-9v5q-2gwq-q9hq
  • org.geoserver:gs-restconfig (Maven) Vendor— Affected 2.24.0 to before 2.24.1 Fixed in 2.24.1 Patch available GHSA-9v5q-2gwq-q9hq

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*before 2.23.4Vulnerablegeoserver
cpe:2.3:a:geoserver:geoserver:2.24.0:*:*:*:*:*:*:*2.24.0Vulnerablegeoserver
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* Versions before 2.23.4 Vulnerable ·geoserver
  • cpe:2.3:a:geoserver:geoserver:2.24.0:*:*:*:*:*:*:* Versions 2.24.0 Vulnerable ·geoserver

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.23.4
  • Fix · GHSA-9v5q-2gwq-q9hq org.geoserver:gs-platform (Maven) Fixed in 2.23.4 Advisory →
  • Fix · GHSA-9v5q-2gwq-q9hq org.geoserver:gs-restconfig (Maven) Fixed in 2.23.4 Advisory →
  • Fix · GHSA-9v5q-2gwq-q9hq org.geoserver:gs-platform (Maven) Fixed in 2.24.1 Advisory →
  • Fix · GHSA-9v5q-2gwq-q9hq org.geoserver:gs-restconfig (Maven) Fixed in 2.24.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-51444
  2. 2026-10-03 Alias added: GHSA-9v5q-2gwq-q9hq

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
  • TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
  • TI-2024-16266 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat CVSS 3.1HIGH 7.5
See all 16 →

Sources