GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.2 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another administrator’s browser when viewed in the GWC Seed Form. Access to the GWC Seed Form is limited to full administrators by default and granting non-administrators access to this endpoint is not recommended. Versions 2.23.2 and 2.24.1 contain a fix for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | before 2.23.2; = 2.24.0 | 2.23.2 | Patch available | CNA |
| — | org.geoserver:gs-gwc-rest (Maven) | before 2.23.2 | 2.23.2 | Patch available | GHSA-56r3-f536-5gf7 |
| — | org.geoserver:gs-gwc-rest (Maven) | 2.24.0 to before 2.24.1 | 2.24.1 | Patch available | GHSA-56r3-f536-5gf7 |
- geoserver Vendorgeoserver Affected before 2.23.2; = 2.24.0 Fixed in 2.23.2 Patch available CNA
- org.geoserver:gs-gwc-rest (Maven) Vendor— Affected before 2.23.2 Fixed in 2.23.2 Patch available GHSA-56r3-f536-5gf7
- org.geoserver:gs-gwc-rest (Maven) Vendor— Affected 2.24.0 to before 2.24.1 Fixed in 2.24.1 Patch available GHSA-56r3-f536-5gf7
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.23.2
- Fix · GHSA-56r3-f536-5gf7 org.geoserver:gs-gwc-rest (Maven) Fixed in 2.23.2 Advisory →
- Fix · GHSA-56r3-f536-5gf7 org.geoserver:gs-gwc-rest (Maven) Fixed in 2.24.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23643
- 2026-10-03 Alias added: GHSA-56r3-f536-5gf7
References
Advisory 2
More Geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
- TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
- TI-2024-16266 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat CVSS 3.1HIGH 7.5
Sources
- CVE-2024-23643 · CVE Program
- CVE-2024-23643 · NVD
- FIRST EPSS
- GHSA-56r3-f536-5gf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences