GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.3 and 2.24.0 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources that will execute in the context of another administrator's browser when viewed in the REST Resources API. Access to the REST Resources API is limited to full administrators by default and granting non-administrators access to this endpoint should be carefully considered as it may allow access to files containing sensitive information. Versions 2.23.3 and 2.24.0 contain a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | before 2.23.3 | 2.23.3 | Patch available | CNA |
| — | org.geoserver:gs-restconfig (Maven) | before 2.23.3 | 2.23.3 | Patch available | GHSA-fh7p-5f6g-vj2w |
- geoserver Vendorgeoserver Affected before 2.23.3 Fixed in 2.23.3 Patch available CNA
- org.geoserver:gs-restconfig (Maven) Vendor— Affected before 2.23.3 Fixed in 2.23.3 Patch available GHSA-fh7p-5f6g-vj2w
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.23.3
- Fix · GHSA-fh7p-5f6g-vj2w org.geoserver:gs-restconfig (Maven) Fixed in 2.23.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-51445
- 2026-10-03 Alias added: GHSA-fh7p-5f6g-vj2w
References
More Geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
- TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
- TI-2024-16266 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat CVSS 3.1HIGH 7.5
Sources
- CVE-2023-51445 · CVE Program
- CVE-2023-51445 · NVD
- FIRST EPSS
- GHSA-fh7p-5f6g-vj2w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences