An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because…
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be used.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01065 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed langchain (PyPI): 0.0.247
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | langchain (PyPI) | before 0.0.247 | 0.0.247 | Patch available | GHSA-2qmj-7962-cjq8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- langchain (PyPI) Vendor— Affected before 0.0.247 Fixed in 0.0.247 Patch available GHSA-2qmj-7962-cjq8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:langchain:langchain:0.0.199:*:*:*:*:*:*:* | 0.0.199 | Vulnerable | langchain-ai |
- cpe:2.3:a:langchain:langchain:0.0.199:*:*:*:*:*:*:* Versions 0.0.199 Vulnerable ·langchain-ai
Remediation
- Fix · GHSA-2qmj-7962-cjq8 langchain (PyPI) Fixed in 0.0.247 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36258
- 2026-10-03 Alias added: GHSA-2qmj-7962-cjq8
References
Other 10
- https://github.com/langchain-ai/langchain/issues/5872
- https://github.com/langchain-ai/langchain/issues/5872#issuecomment-1697785619
- https://github.com/langchain-ai/langchain/pull/6003
- https://github.com/langchain-ai/langchain/pull/7870
- https://github.com/langchain-ai/langchain/pull/8425
- https://github.com/langchain-ai/langchain/commit/8ba9835b925473655914f63822775679e03ea137
- https://github.com/langchain-ai/langchain/commit/e294ba475a355feb95003ed8f1a2b99942509a9e
- https://github.com/langchain-ai/langchain/commit/fab24457bcf8ede882abd11419769c92bc4e7751
- https://github.com/hwchase17/langchain
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-98.yaml
More langchain-ai Langchain vulnerabilities
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
- TI-2023-18150 An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-36258 · CVE Program
- CVE-2023-36258 · NVD
- FIRST EPSS
- GHSA-2qmj-7962-cjq8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences