Priority HIGH 82
An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01521 · Published 2023-08-15 · Fixed in 0.0.325 CWE-74
Priority HIGH 82
An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.016 · Published 2023-09-01 · Fixed in 0.0.308, 2.8.5 CWE-94
Priority HIGH 82
An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to execute arbitrary code via the from_math_prompt and from_colored_object_prompt functions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01822 · Published 2023-08-15 · Fixed in 0.0.236 CWE-74
Priority HIGH 82
An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01405 · Published 2023-08-15 · Fixed in 0.0.247 CWE-94
Priority HIGH 82
An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a JSON file to load_prompt.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03412 · Published 2023-08-22 · Fixed in 0.0.312 CWE-94
Priority HIGH 82
An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be used.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01065 · Published 2023-07-03 · Fixed in 0.0.247 CWE-94
Priority HIGH 82
An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0188 · Published 2023-07-06 · Fixed in 0.0.247 CWE-74
Priority HIGH 82
An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain, affected functions include from_math_prompt and from_colored_object_prompt.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0117 · Published 2023-08-05 · Fixed in 0.0.236 CWE-94
Priority HIGH 82
Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00935 · Published 2023-06-20 · Fixed in 0.0.247
Priority HIGH 77
LangChain versions up to and including 0.3.1 contain a regular expression denial-of-service (ReDoS) vulnerability in the MRKLOutputParser.parse() method (libs/langchain/langchain/agents/mrkl/output_parser.py).
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.00481 · Published 2026-01-12 · Will not fix CWE-1333
Priority HIGH 76
A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchai…
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.21019 · Published 2025-06-23 · Fixed in 0.0.28 CWE-918
Priority HIGH 76
In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec method.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.39653 · Published 2023-04-05 · No fix listed CWE-74
Priority HIGH 75
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.13738 · Published 2024-10-29 · Partial fix · 0.3.0, 0.2.19 +1 CWE-89
Priority HIGH 75
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00311 · Published 2024-10-29 · Fixed in 0.3.1, 0.3.3 CWE-89
Priority HIGH 71
langchain-ai/langchain is vulnerable to path traversal due to improper limitation of a pathname to a restricted directory ('Path Traversal') in its LocalFileStore functionality.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01871 · Published 2024-04-16 · Fixed in 0.0.353 CWE-22
Priority HIGH 70
LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01726 · Published 2024-03-03 · Fixed in 0.0.339, 0.1.30 CWE-31
Priority HIGH 70
LangChain before 0.0.317 allows SSRF via document_loaders/recursive_url_loader.py because crawling can proceed from an external server to an internal server.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.47625 · Published 2023-10-19 · Fixed in 0.0.317 CWE-918
Priority HIGH 68
With the following crawler configuration: ```python from bs4 import BeautifulSoup as Soup url = "https://example.com" loader = RecursiveUrlLoader( url=url, max_depth=2, extractor=lambda x: Soup(x, "html.parser").text ) d…
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.00517 · Published 2024-02-24 · Fixed in 0.1.0 CWE-918
Priority HIGH 67
A vulnerability in the FAISS.deserialize_from_bytes function of langchain-ai/langchain allows for pickle deserialization of untrusted data.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.00361 · Published 2024-09-17 · Fixed in 0.2.9, 0.2.4 CWE-502
Priority HIGH 67
A Server-Side Request Forgery (SSRF) vulnerability exists in the Web Research Retriever component of langchain-ai/langchain version 0.1.5.
CVSS 3.1HIGH 7.7· Network · Low privileges · No interaction · EPSS 0.00691 · Published 2024-06-06 · Fixed in 0.2.9 CWE-918
Priority MEDIUM 60
A vulnerability in the langchain-ai/langchain repository allows for a Billion Laughs Attack, a type of XML External Entity (XXE) exploitation.
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00764 · Published 2024-03-26 · Fixed in 0.1.35 CWE-776
Priority MEDIUM 55
A Denial-of-Service (DoS) vulnerability exists in the `SitemapLoader` class of the `langchain-ai/langchain` repository, affecting all versions.
CVSS 3.1MEDIUM 4.7· Local · Low privileges · No interaction · EPSS 0.00304 · Published 2024-06-06 · Fixed in 0.2.5 CWE-674
Priority MEDIUM 45
Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the JIRA API wrapper).
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01667 · Published 2023-06-14 · Fixed in 0.0.225 CWE-78
Priority MEDIUM 43
A vulnerability was found in LangChain langchain_community 0.0.26.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00578 · Published 2024-03-01 · No fix listed CWE-918
Priority MEDIUM 42
LangChain is a framework for building agents and LLM-powered applications.
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.00406 · Published 2026-05-26 · Partial fix · 0.3.85, 1.3.3 CWE-502
Load more