Apache Superset: Unnecessary read permissions within the Gamma role
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 2.1.2 | 2.1.2 | Patch available | CNA |
| — | apache-superset (PyPI) | before 2.1.2 | 2.1.2 | Patch available | GHSA-vv65-fjfj-4736 |
- Apache Superset VendorApache Affected before 2.1.2 Fixed in 2.1.2 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 2.1.2 Fixed in 2.1.2 Patch available GHSA-vv65-fjfj-4736
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 2.1.2
- Fix · GHSA-vv65-fjfj-4736 apache-superset (PyPI) Fixed in 2.1.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 2.1.2
3 records Highest priority Priority HIGH 1 HIGH, 2 LOW
Other records, highest priority first
- TI-2023-21408 Apache Superset: Privilege escalation with default examples databasePriority HIGH 71
- TI-2023-23406 Apache Superset: Stored XSS on API endpointPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2023-42501
- 2026-10-03 Alias added: GHSA-vv65-fjfj-4736
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-42501 · CVE Program
- CVE-2023-42501 · NVD
- FIRST EPSS
- GHSA-vv65-fjfj-4736 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences