Apache Superset: Stored XSS on API endpoint
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2. Users are recommended to upgrade to version 2.1.2, which fixes this issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 2.1.2 | 2.1.2 | Patch available | CNA |
| — | apache-superset (PyPI) | before 2.1.2 | 2.1.2 | Patch available | GHSA-wq8q-99p5-xfrw |
- Apache Superset VendorApache Affected before 2.1.2 Fixed in 2.1.2 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 2.1.2 Fixed in 2.1.2 Patch available GHSA-wq8q-99p5-xfrw
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 2.1.2
- Fix · GHSA-wq8q-99p5-xfrw apache-superset (PyPI) Fixed in 2.1.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 2.1.2
3 records Highest priority Priority HIGH 1 HIGH, 2 LOW
Other records, highest priority first
- TI-2023-21408 Apache Superset: Privilege escalation with default examples databasePriority HIGH 71
- TI-2023-22661 Apache Superset: Unnecessary read permissions within the Gamma rolePriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2023-43701
- 2026-10-03 Alias added: GHSA-wq8q-99p5-xfrw
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-43701 · CVE Program
- CVE-2023-43701 · NVD
- FIRST EPSS
- GHSA-wq8q-99p5-xfrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences