Broken Access control on Graphs Feature in LibreNMS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems. In affected versions of LibreNMS when a user accesses their device dashboard, one request is sent to `graph.php` to access graphs generated on the particular Device. This request can be accessed by a low privilege user and they can enumerate devices on librenms with their id or hostname. Leveraging this vulnerability a low privilege user can see all devices registered by admin users. This vulnerability has been addressed in commit `489978a923` which has been included in release version 23.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 23.11.0 | 23.11.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 23.11.0 | 23.11.0 | Patch available | GHSA-fpq5-4vwm-78x4 |
- librenms Vendorlibrenms Affected before 23.11.0 Fixed in 23.11.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 23.11.0 Fixed in 23.11.0 Patch available GHSA-fpq5-4vwm-78x4
Remediation
- Fix · CNA librenms (librenms) Fixed in 23.11.0
- Fix · GHSA-fpq5-4vwm-78x4 librenms/librenms (Packagist) Fixed in 23.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-48294
- 2026-10-03 Alias added: GHSA-fpq5-4vwm-78x4
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-48294 · CVE Program
- CVE-2023-48294 · NVD
- FIRST EPSS
- GHSA-fpq5-4vwm-78x4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences