Apache Superset: Privilege Escalation Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 2.1.2; 3.0.0 to before 3.0.2 | 2.1.2, 3.0.2 | Patch available | CNA |
| — | apache-superset (PyPI) | before 2.1.3 | 2.1.3 | Patch available | GHSA-g49j-j489-3xpf |
| — | apache-superset (PyPI) | 3.0.0 to before 3.0.2 | 3.0.2 | Patch available | GHSA-g49j-j489-3xpf |
- Apache Superset VendorApache Affected before 2.1.2; 3.0.0 to before 3.0.2 Fixed in 2.1.2, 3.0.2 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 2.1.3 Fixed in 2.1.3 Patch available GHSA-g49j-j489-3xpf
- apache-superset (PyPI) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-g49j-j489-3xpf
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 2.1.2, 3.0.2
- Fix · GHSA-g49j-j489-3xpf apache-superset (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-g49j-j489-3xpf apache-superset (PyPI) Fixed in 3.0.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 2.1.2, 3.0.2
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2023-27147 Apache Superset: SQL Injection on where_in JINJA macroPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49734
- 2026-10-03 Alias added: GHSA-g49j-j489-3xpf
References
Advisory 3
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-49734 · CVE Program
- CVE-2023-49734 · NVD
- FIRST EPSS
- GHSA-g49j-j489-3xpf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences