Apache Superset: SQL Injection on where_in JINJA macro
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 2.1.2; 3.0.0 to before 3.0.2 | 2.1.2, 3.0.2 | Patch available | CNA |
| — | apache-superset (PyPI) | before 2.1.3 | 2.1.3 | Patch available | GHSA-jfxj-xf67-x723 |
| — | apache-superset (PyPI) | 3.0.0 to before 3.0.2 | 3.0.2 | Patch available | GHSA-jfxj-xf67-x723 |
- Apache Superset VendorApache Affected before 2.1.2; 3.0.0 to before 3.0.2 Fixed in 2.1.2, 3.0.2 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 2.1.3 Fixed in 2.1.3 Patch available GHSA-jfxj-xf67-x723
- apache-superset (PyPI) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-jfxj-xf67-x723
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 2.1.2, 3.0.2
- Fix · GHSA-jfxj-xf67-x723 apache-superset (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-jfxj-xf67-x723 apache-superset (PyPI) Fixed in 3.0.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 2.1.2, 3.0.2
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2023-27145 Apache Superset: Privilege Escalation VulnerabilityPriority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49736
- 2026-10-03 Alias added: GHSA-jfxj-xf67-x723
References
Advisory 3
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-49736 · CVE Program
- CVE-2023-49736 · NVD
- FIRST EPSS
- GHSA-jfxj-xf67-x723 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences