Read the docs
TI-2024-01683 Aliases CVE-2024-1807GHSA-94f2-m645-cfq4

Product Sort and Display for WooCommerce <= 2.4.1 - Missing Authorization

Priority LOW 36CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The Product Sort and Display for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the psad_update_product_cat_custom_meta_ajax function in all versions up to, and including, 2.4.1. This makes it possible for unauthenticated attackers to hide product categories.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00561 46th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
a3revProduct Sort and Display for WooCommerceup to 2.4.1—No fix listedCNA
  • Product Sort and Display for WooCommerce Vendora3rev Affected up to 2.4.1 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1807
  2. 2026-10-03 Alias added: GHSA-94f2-m645-cfq4

References

  • TI-2023-00091 Page View Count < 2.6.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-00358 Page Views Count < 2.4.15 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-11423 Compare Products for WooCommerce <= 3.2.1 - Unauthenticated PHP Object Injection CVSS 3.1HIGH 8.1
  • TI-2025-02460 Page View Count 2.8.0 - 2.8.4 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update CVSS 3.1HIGH 8.1
  • TI-2024-25904 WordPress Predictive Search for WooCommerce plugin <= 6.0.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-16151 WordPress Predictive Search for WooCommerce plugin <= 5.8.0 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
See all 15 →

Sources