Compare Products for WooCommerce <= 3.2.1 - Unauthenticated PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The Compare Products for WooCommerce plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.2.1 via deserialization of untrusted input from the 'woo_compare_list' cookie. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12313
- 2026-10-03 Alias added: GHSA-p3wm-hf9c-vv27
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/638e8e67-38b3-4fc4-bd77-8f268030a93a?source=cve
- https://plugins.trac.wordpress.org/browser/woocommerce-compare-products/trunk/classes/class-wc-compare-functions.php#L219
- https://plugins.trac.wordpress.org/browser/woocommerce-compare-products/trunk/classes/class-wc-compare-functions.php#L237
- https://plugins.trac.wordpress.org/browser/woocommerce-compare-products/trunk/classes/class-wc-compare-functions.php#L256
- https://plugins.trac.wordpress.org/browser/woocommerce-compare-products/trunk/classes/class-wc-compare-functions.php#L275
- https://plugins.trac.wordpress.org/changeset/3215166/
More a3rev vulnerabilities
- TI-2023-00091 Page View Count < 2.6.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-00358 Page Views Count < 2.4.15 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2025-02460 Page View Count 2.8.0 - 2.8.4 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update CVSS 3.1HIGH 8.1
- TI-2024-01683 Product Sort and Display for WooCommerce <= 2.4.1 - Missing Authorization CVSS 3.1MEDIUM 6.5
- TI-2024-25904 WordPress Predictive Search for WooCommerce plugin <= 6.0.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-16151 WordPress Predictive Search for WooCommerce plugin <= 5.8.0 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-12313 · CVE Program
- CVE-2024-12313 · NVD
- FIRST EPSS
- GHSA-p3wm-hf9c-vv27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences