Read the docs
TI-2024-07875 Aliases CVE-2024-8494GHSA-c8w7-9g9r-2466

Information disclosure in Elementor Website Builder Pro

Priority LOW 29CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.

Summary

The Elementor Website Builder Pro plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.25.10 via the 'elementor-template' shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the content of Private, Pending, and Draft Templates. The vulnerability was partially patched in version 3.24.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00312 24th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElementorElementor Website Builder Proup to 3.25.10—No fix listedCNA
  • Elementor Website Builder Pro VendorElementor Affected up to 3.25.10 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elementor:website_builder:*:*:*:*:pro:wordpress:*:*before 3.25.11VulnerableElementor
  • cpe:2.3:a:elementor:website_builder:*:*:*:*:pro:wordpress:*:* Versions before 3.25.11 Vulnerable ·Elementor

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-8494
  2. 2026-10-03 Alias added: GHSA-c8w7-9g9r-2466

References

  • TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
  • TI-2023-00313 Elementor Website Builder < 3.12.2 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-26607 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2023-25676 WordPress Elementor Website Builder Plugin <= 3.16.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2021-07171 Elementor < 3.4.8 - DOM Cross-Site-Scripting CVSS 3.1MEDIUM 6.1
See all 36 →

Sources