Stored XSS in phpipam/phpipam
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the destination address field of the NAT tool, which can be executed when a user interacts with the field. The impact of this vulnerability includes the potential theft of user cookies, unauthorized access to user accounts, and redirection to malicious websites. The issue has been fixed in version 1.7.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA phpipam/phpipam (phpipam) Fixed in 1.7.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
phpipam/phpipam 1.7.0
9 records Highest priority Priority HIGH 1 HIGH, 8 MEDIUM
Other records, highest priority first
- TI-2024-09932 Cookie without Secure attribute in phpipam/phpipamPriority HIGH 72
- TI-2024-09941 Cross-Site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 60
- TI-2024-09934 Stored Cross-site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 60
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10723
- 2026-10-03 Alias added: GHSA-prx2-6cc4-7qq5
References
More Phpipam vulnerabilities
- TI-2024-09932 Cookie without Secure attribute in phpipam/phpipam CVSS 3.1HIGH 7.5
- TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
- TI-2023-01145 SQL Injection in phpipam/phpipam CVSS 3.1HIGH 7.2
- TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
- TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
- TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
Sources
- CVE-2024-10723 · CVE Program
- CVE-2024-10723 · NVD
- FIRST EPSS
- GHSA-prx2-6cc4-7qq5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences