Compare Products for WooCommerce <= 3.2.1 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Compare Products for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘s_feature’ parameter in all versions up to, and including, 3.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12435
- 2026-10-03 Alias added: GHSA-cfgr-f4jj-3jjf
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f74c419a-56de-4190-925d-876d32f712e1?source=cve
- https://plugins.trac.wordpress.org/browser/woocommerce-compare-products/trunk/admin/classes/class-wc-compare-fields.php#L392
- https://plugins.trac.wordpress.org/browser/woocommerce-compare-products/trunk/admin/classes/class-wc-compare-fields.php#L397
- https://plugins.trac.wordpress.org/changeset/3215166/
More a3rev vulnerabilities
- TI-2023-00091 Page View Count < 2.6.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-00358 Page Views Count < 2.4.15 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-11423 Compare Products for WooCommerce <= 3.2.1 - Unauthenticated PHP Object Injection CVSS 3.1HIGH 8.1
- TI-2025-02460 Page View Count 2.8.0 - 2.8.4 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update CVSS 3.1HIGH 8.1
- TI-2024-01683 Product Sort and Display for WooCommerce <= 2.4.1 - Missing Authorization CVSS 3.1MEDIUM 6.5
- TI-2024-25904 WordPress Predictive Search for WooCommerce plugin <= 6.0.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-12435 · CVE Program
- CVE-2024-12435 · NVD
- FIRST EPSS
- GHSA-cfgr-f4jj-3jjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences