Read the docs
TI-2024-12289 Aliases CVE-2024-13245GHSA-2gj6-558v-rq2w

CKEditor 4 LTS - WYSIWYG HTML editor - Moderately critical - Cross Site Scripting - SA-CONTRIB-2024-009

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CKEditor 4 LTS - WYSIWYG HTML editor allows Cross-Site Scripting (XSS).This issue affects CKEditor 4 LTS - WYSIWYG HTML editor: from 1.0.0 before 1.0.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00229 13th percentileScored 2026-11-07
Fix Fixed CKEditor 4 LTS - WYSIWYG HTML editor (Drupal): 1.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCKEditor 4 LTS - WYSIWYG HTML editor1.0.0 to before 1.0.11.0.1Patch availableCNA
  • CKEditor 4 LTS - WYSIWYG HTML editor VendorDrupal Affected 1.0.0 to before 1.0.1 Fixed in 1.0.1 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:cksource:ckeditor_4:1.0.0:*:*:*:lts:drupal:*:*1.0.0VulnerableCKSource
cpe:2.3:a:cksource:ckeditor_4:1.0.1:*:*:*:lts:drupal:*:*1.0.1VulnerableCKSource
  • cpe:2.3:a:cksource:ckeditor_4:1.0.0:*:*:*:lts:drupal:*:* Versions 1.0.0 Vulnerable ·CKSource
  • cpe:2.3:a:cksource:ckeditor_4:1.0.1:*:*:*:lts:drupal:*:* Versions 1.0.1 Vulnerable ·CKSource

Remediation

  • Fix · CNA CKEditor 4 LTS - WYSIWYG HTML editor (Drupal) Fixed in 1.0.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13245
  2. 2026-10-03 Alias added: GHSA-2gj6-558v-rq2w

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources