Drupal REST & JSON API Authentication - Moderately critical - Access bypass - SA-CONTRIB-2024-022
Priority MEDIUM 50CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
Incorrect Authorization vulnerability in Drupal Drupal REST & JSON API Authentication allows Forceful Browsing.This issue affects Drupal REST & JSON API Authentication: from 0.0.0 before 2.0.13.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Fix Fixed Drupal REST & JSON API Authentication (Drupal): 2.0.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal REST & JSON API Authentication | 0.0.0 to before 2.0.13 | 2.0.13 | Patch available | CNA |
- Drupal REST & JSON API Authentication VendorDrupal Affected 0.0.0 to before 2.0.13 Fixed in 2.0.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rest_\&_json_api_authentication_project:rest_\&_json_api_authentication:*:*:*:*:*:drupal:*:* | before 2.0.13 | Vulnerable | Rest & Json Api Authentication Project |
- cpe:2.3:a:rest_\&_json_api_authentication_project:rest_\&_json_api_authentication:*:*:*:*:*:drupal:*:* Versions before 2.0.13 Vulnerable ·Rest & Json Api Authentication Project
Remediation
- Fix · CNA Drupal REST & JSON API Authentication (Drupal) Fixed in 2.0.13
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13258
- 2026-10-03 Alias added: GHSA-7649-pgpq-cpch
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2024-13258 · CVE Program
- CVE-2024-13258 · NVD
- FIRST EPSS
- GHSA-7649-pgpq-cpch · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences